Etiquetado: Modernizr

Compatibilidad con navegadores antiguos

HTML 5 Shiv

Este pequeño script hará que los navegadores que no soporten las etiquetas HTML 5 las entiendan. Se pone en el <head> y ya está, una cosa menos de la que preocuparnos.

<!--[if lt IE 9]>
<script src="dist/html5shiv.js"></script>
<![endif]-->

http://code.google.com/p/html5shiv/

Modernizr

Librería JavaScript que detecta la compatibilidad del navegador con HTML5 y CSS3

http://modernizr.com

Polyffils

Esta palabra  quiere decir hack, los recursos que utilicemos para que nuestro desarrollo se vea bien en otro navegador sin soporte se denominan así.

Iba a hacer una lista de los más útiles, pero como no es muy productivo reinventar la rueda os dejo un enlace MUST que ha creado Paul Irish http://paulirish.com/ que tiene que estar en los marcadores de cada uno de nosotros.

https://github.com/Modernizr/Modernizr/wiki/HTML5-Cross-Browser-Polyfills

 

Estaría bien que contribuyerais nombrando los polyfills que usais vosotros, para que podamos tener feedback entre todos y podamos aprender más.

¿Y tu cuales usas?